更新了cocoapods出现了这样的问题

$ sudo pod install

/Users/YSQ/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/gems/2.0.0/gems/claide-0.5.0/lib/claide/command.rb:328:in `help!': [!] You cannot run CocoaPods as root. (CLAide::Help)

CocoaPods, the Objective-C library package manager.

Commands:

* help       Show help for the given command.
* init       Generate a Podfile for the current directory.
- install    Install project dependencies
* ipc        Inter-process communication
* lib        Develop pods
* list       List pods
* outdated   Show outdated project dependencies
* push       Push new specifications to a spec-repo
* repo       Manage spec-repositories
* search     Searches for pods
* setup      Setup the CocoaPods environment
* spec       Manage pod specs
* update     Update outdated project dependencies

Options:

--silent    Show nothing
--version   Show the version of CocoaPods
--no-ansi   Show output without ANSI codes
--verbose   Show more debugging information
--help      Show help banner of specified command
from /Users/YSQ/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/gems/2.0.0/gems/cocoapods-0.32.1/lib/cocoapods/command.rb:46:in `run'
from /Users/YSQ/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/gems/2.0.0/gems/cocoapods-0.32.1/bin/pod:33:in `<top (required)>'
from /Users/YSQ/.rvm/rubies/ruby-2.0.0-p247/bin/pod:23:in `load'
from /Users/YSQ/.rvm/rubies/ruby-2.0.0-p247/bin/pod:23:in `<main>'
查看回复