Godep如何处理依赖包不同版本的问题

如下图,A是我的项目,B和C是github上依赖的包,A也直接依赖C,但与B依赖的版本不同。
这种情况下Godep是否能够处理呢,谢谢

如何这样组织项目,是否会有问题呢

A
|_ vendor
   |_ B
      |_ vendor
         |_ C(1.0)
   |_ C(2.0)
查看回复